Knowledgebase
What versions of Lightroom are the plugins compatible with?
Posted by Jim Keir on 14 March 2012 11:41 AM

Most of the plugins here are tested and compatible with Lightroom 2.2 and up, although many now require at least Lightroom 4. New versions of Lightroom will be tested as they appear.

They are not compatible with the new cloud-based version of Lightroom, which is a very much cut-down program compared to what is now called "Lightoom CC Classic".

(1627 vote(s))
This article was helpful
This article was not helpful

Help Desk Software by Kayako Fusion