Knowledgebase
Logging in to Alamy causes "Alamy's Server said 500" error
Posted by Jim Keir on 06 May 2010 09:58 AM
You try to log in to Alamy using the Lightroom plugin and receive an error:

"Alamy's server said 500".

The '500' is a standard HTTP error code meaning "internal server error". This is being returned by Alamy's web server. This usually happens while uploading images, but also sometimes during login.

If you receive this error, please check in your Documents folder for a file called "AlamyExport.log". In the case of a failed login, this will contain the actual server response as well as the "500" code. For example:


2010-05-06 11:07:29 +0200, TRACE Fetch UserID using https://secure.alamy.com/logon.asp?returnurl=http://www.alamy.com/stock-photography-link-to-alamy.asp
2010-05-06 11:07:31 +0200, TRACE Response received
2010-05-06 11:07:31 +0200, TRACE Fallback on parsing HTML
2010-05-06 11:07:31 +0200, TRACE Auth failed. Response =
2010-05-06 11:07:31 +0200, TRACE <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML dir=ltr><HEAD><TITLE>The page cannot be displayed</TITLE>

...

<H2 style="FONT: 8pt/11pt verdana; COLOR: #000000">500 Internal Server Error - The network logon failed. (1790)<BR>Internet Security and Acceleration Server</H2>
</FONT></TD></TR></TBODY></TABLE></BODY></HTML>

2010-05-06 11:07:31 +0200, TRACE (End response)
2010-05-06 11:07:31 +0200, TRACE Server status: 500
2010-05-06 11:07:31 +0200, TRACE Lightroom: 3.0
2010-05-06 11:07:31 +0200, TRACE Headers:
2010-05-06 11:07:31 +0200, TRACE Cache-Control = no-cache
2010-05-06 11:07:31 +0200, TRACE Pragma = no-cache
2010-05-06 11:07:31 +0200, TRACE Content-Type = text/html
2010-05-06 11:07:31 +0200, TRACE Content-Length = 1731
2010-05-06 11:07:31 +0200, TRACE status = 500
2010-05-06 11:07:31 +0200, TRACE statusDes = internal server error


If you receive this error, please raise a ticket here but also with Alamy. This shows that their servers are overloaded or broken, and they should be advised as soon as possible. Send them the specific error message that appears in your AlamyExport.log, similar to the one highlighted in red above.
(3132 vote(s))
This article was helpful
This article was not helpful

Comments (1)
raf sanchez
23 August 2010 03:20 PM
I am evaluating this plugin but am getting a "Alamy's Server said 200" error - what does this error relate to?

*** Response
This is caused by a bug in Lightroom 3.0 for MacOS X. It's fixed in the Lightroom 3.2 and above.
Help Desk Software by Kayako Fusion